Wednesday, 8 July 2009

How-To: Install VLC 1.0 from the Ubuntu PPA Repository

Since most of the users found the compilation method to have either too many steps or too complicated, here's a tutorial on how to install VLC 1.0.0 using the Ubuntu VLC PPA repository. Just follow the steps below:

First, download and install the trusted key:

sudo apt-key adv --recv-keys --keyserver 7613768D

This commands tells apt-key to download key 7613768D from and add it to your trusted repository keys.

Next, we need to edit the /etc/apt/sources.list file with root privileges (sudo nano /etc/apt/sources.list or gksudo gedit /etc/apt/sources.list) and add the following two repository lines:

deb jaunty main
deb-src jaunty main

Make sure to save the file when you're done. Alternately, this can be done as:

sudo bash -c "echo 'deb jaunty main' >> /etc/apt/sources.list"

sudo bash -c "echo 'deb-src jaunty main' >> /etc/apt/sources.list"

These two commands will append the two lines mentioned earlier to /etc/apt/sources.list.

Next, update the package lists:

sudo apt-get update

Then, just install VLC the usual way:

sudo apt-get install vlc

Or you can use Synaptic (System -> Administration -> Synaptic Package Manager), search for package vlc and install it from there.


Anonymous said...

Thank you for providing simple step-by-step instructions for those of us who are just learning about ubuntu!

Craciun Dan said...

Thanks for the words of appreciation. I'm glad I could help :)

fermilevel said...

Thanks dude. nice how to . I am upgraded to the new vlc

benny said...

I have no idea how to start the VLC Player after compile and installing it on your guide.

Anonymous said...

I had to refresh my updates and install them after following this process for VLC 1.0 to work.

Works perfectly but thought I'd just add that in.

TheParadox2 said...

I got a funky error message:

theparadox@theparadox-desktop:~$ sudo apt-get install vlc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vlc: Depends: vlc-nox (= 1.0.0-1~ppa3) but it is not going to be installed
Depends: libqtgui4 (>= 4.5.1) but it is not going to be installed
Depends: libsdl-image1.2 (>= 1.2.5) but it is not installable
Depends: libtar but it is not installable
Depends: libx264-65 (>= 1:0.svn20081230) but it is not installable
E: Broken packages

what's wrong with my setup, i check the address and sources listing.

Nicholas said...

Thanks, works perfectly.It installed some other Qt updates, but I guess VLC needs them.

TuxDnerD said...

Thanks for the tip on how to get to vlc 1...was tryin to understand the ppa method..your method was too easy! thanks again!